King Computer Solutions
spacer
02.16.2010

Upgrading WordPress running on IIS

The ideal WordPress installation runs on a linux+apache platform but with a little tweaking, runs just fine on IIS. One common problem is with the installation of plugins and the application of the automatic upgrades of WordPress. You’ll see something like:

“Downloading update from http://wordpress.org/wordpress-2.x.x

Download failed.: Could not copy files.

Installation Failed”

The problem here is that WordPress does not have permission to modify itself. To correct this, adjust the Security permissions on your WordPress folder. Add the NETWORK user (not Network System nor ISYS NETWORK) and give it the Modify flag. After you’ve applied the new setting, your upgrade should proceed smoothly.